Getting on to EASTMANS forum

sneakypete

Veteran member
Aug 9, 2011
2,751
191
Oakdale Ca.
Scott,
Just wondering why it's been So difficult to get onto the forum site? My old way puts me thru the new EASTMANS subscriptions / Electronic / store site. Must of the time it says no server? Help
 

ScottR

Eastmans' Staff / Moderator
Staff member
Feb 3, 2014
6,932
1,823
www.eastmans.com
If you go to our homepage it is in the menu bar.

The forum address hasn't changed. forum.eastmans.com is what you can bookmark for direct access.
 

bghunter

Active Member
Jun 23, 2015
452
20
Granite Bay, CA
Yes, and I noticed if I post anything, that thread is not showing on the New Post page. Does it have anything with my cookies? I have same issue on two computers and my cell phone.
 

sneakypete

Veteran member
Aug 9, 2011
2,751
191
Oakdale Ca.
I cleared my cache! It seems the only way I can get on is thru an old posting. I got on this time thru the mule deer thread! If I type in EASTMANS, comes up as server not found.
 

Horsenhike

Very Active Member
Nov 11, 2015
668
0
Eastern SD
I cleared my cache! It seems the only way I can get on is thru an old posting. I got on this time thru the mule deer thread! If I type in EASTMANS, comes up as server not found.
Wierd. I can only access with my phone through the Mule Deer forum. Wi-fi or any other avenue results in server not found.
 

mntnguide

Very Active Member
It's up on the new site. Cool new technology coming too.


Sent from my iPhone using Tapatalk
Thanks Scott...i got it figured out..I had to reset my password, but i still cant get it to show up on my phone app...Are there going to be further refinements to the new digital version?..because in honesty, i cant zoom in or just jump to a page like i could before right now, and im having trouble reading a lot of the text throughout the articles to the point i just stopped because i cant when some of the font is against lite backgrounds. .
 

ScottR

Eastmans' Staff / Moderator
Staff member
Feb 3, 2014
6,932
1,823
www.eastmans.com
Thanks Scott...i got it figured out..I had to reset my password, but i still cant get it to show up on my phone app...Are there going to be further refinements to the new digital version?..because in honesty, i cant zoom in or just jump to a page like i could before right now, and im having trouble reading a lot of the text throughout the articles to the point i just stopped because i cant when some of the font is against lite backgrounds. .
Great feedback. Designer will address this.


Sent from my iPhone using Tapatalk
 

JimP

Veteran member
Mar 28, 2016
6,129
6,279
68
Gypsum, Co
I have been having problems getting on for the last day and a half. I even went to Eastmans.com and clicked on the Forums tag and it brought me to the "can't find website" I just figured that it had been hacked and they were working on it.

I'll see tomorrow morning when I try to log on.